× Creating OpenSim accounts during Joomla! registration

Registration Issue Following Upgrade

1 week 2 days ago #3555 by Ton
Hi and thanks for your ideas on this. I upgraded from 0.3.1.6 dev under Ubuntu 16.04 LTS/PHP 7.2 / Apache2 to 0.3.2.0 under Ubuntu 20.04 LTS / PHP 7.4 /Apache 2

Now, when a user tries to create an new account they get an error when they submit the request. The page that returns instead of the usual page to notify you that you need to verify your email address says:

'Using $this when not in object context.'

If the new user checks their email there is an email verification sent, but if you click on that verification link the user again gets the same message:

'Using $this when not in object context. '

If, as an admin, I go into jOpensim user I find the new user account there. If I manually change the user status to registered and then the user tries to log in they then get the error:

Login failed. The inventory service is not responding. Please notify your login region operator.

In the ROBUST console I see:

Login request for Roger Rabbit at last using viewer 1.8.7.7992, channel Singularity Beta 64, IP xxx.xxx.xxx.xxx, Mac ......., Id0 .......
18:36:14 - [AUTH SERVICE]: Authenticating for dff485b2-70c7-11eb-a751-00155d60f202, user account service present: True
18:36:14 - [HG SUITCASE INVENTORY SERVICE]: GetRootFolder for dff485b2-70c7-11eb-a751-00155d60f202
18:36:14 - [HG SUITCASE INVENTORY SERVICE]: Unable to retrieve local root folder for user dff485b2-70c7-11eb-a751-00155d60f202
18:36:14 - [LLOGIN SERVICE]: Login failed, for Roger Rabbit, reason: unable to retrieve user inventory

Further, if I delete the account in jOpensim user and then manually add it back in everything works as expected, but of course, then I have to tell the user the password I used, so it's a temporary solution at best.

So, sorry for the long windedness, but hopefully there is something in there that is a clue as to what's causing the issues I see and how I can correct them.

Best regards,
Ton.







Attachments:

Please Log in or Create an account to join the conversation.

1 week 2 days ago #3556 by foto50
Hi Ton

What version of jOpenSimRegister is installed?

Usually, this message 'Using $this when not in object context.' should throw a line in the webserver's error logfile ... maybe there is more detail in what file exactly is causing this.

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

1 week 2 days ago #3557 by Ton
FoTo50, thanks for the prompt reply. I will check the Apache logs, but to answer your question, the version is:

User - jOpenSimRegister
Site Plugin 0.3.1.5 2018-08-23 FoTo50 user 10032 10006

which is older than 0.3.2.0, but does it follow they should be the same?

As an aside, I notice that many of the plugins are older versions, see attached image. Is that usually the case? Thanks for your support,

Ton.


Attachments:

Please Log in or Create an account to join the conversation.

1 week 2 days ago #3558 by foto50
Pls upgrade the register plugin to 0.3.1.5.3 from www.jopensim.com/jopensim/downloads1/dow...opensimregister.html as 0.3.1.5 had some issues with a previous update from the component already :blush:

And yes, version numbers not always raise same time for modules/plugins since some of them arent even touched when component gets updated.

Greetz

Please Log in or Create an account to join the conversation.

1 week 2 days ago #3559 by Ton
Hi FoTo50.

So, partial success. I am now able to get through the registration process, thank you! The grid owner received his usual email and through that email approved the new account. The account looks to be enabled and activated in Joomla and the login level has been flipped to regular in jOpensim User.

The new user was able to successfully log into his new account on the web.

However, logging onto the grid failed with the "Login failed. The inventory service is not responding. Please notify your login region operator." The data from the Robust console is below as is output from the Apache2 error log.

So progress, but the new account still cannot log in. What may be stopping the new user from logging in. I should note that we do not offer an avatar at immediate login so our new users always appear as a cloud until they choose a body etc...

Thanks again FoTo50.

Ton.


2021-02-17 07:29:04,293 INFO (65) - OpenSim.Services.LLLoginService.LLLoginService [LLOGIN SERVICE]: Login request for Roger Rabbit at last using viewer 5.1.7.55786, channel Firestorm-Release, IP xxx..., Mac yyy..., Id0 zzz...
2021-02-17 07:29:04,309 DEBUG (65) - OpenSim.Services.AuthenticationService.PasswordAuthenticationService [AUTH SERVICE]: Authenticating for 0e838609-7133-11eb-9fe9-00155d60f202, user account service present: True
2021-02-17 07:29:04,418 DEBUG (65) - OpenSim.Services.HypergridService.HGSuitcaseInventoryService [HG SUITCASE INVENTORY SERVICE]: GetRootFolder for 0e838609-7133-11eb-9fe9-00155d60f202
2021-02-17 07:29:04,434 WARN (65) - OpenSim.Services.HypergridService.HGSuitcaseInventoryService [HG SUITCASE INVENTORY SERVICE]: Unable to retrieve local root folder for user 0e838609-7133-11eb-9fe9-00155d60f202
2021-02-17 07:29:04,481 INFO (65) - OpenSim.Services.LLLoginService.LLLoginService [LLOGIN SERVICE]: Login failed, for Roger Rabbit, reason: unable to retrieve user inventory

.....................................

[Wed Feb 17 15:14:44.590573 2021] [mpm_prefork:notice] [pid 3184] AH00169: caught SIGTERM, shutting down
[Wed Feb 17 15:14:45.027609 2021] [mpm_prefork:notice] [pid 3608] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
[Wed Feb 17 15:14:45.027701 2021] [core:notice] [pid 3608] AH00094: Command line: '/usr/sbin/apache2'
[Wed Feb 17 15:18:58.670956 2021] [php7:notice] [pid 3624] [client 23.239.96.242:51145] PHP Notice: Undefined index: profilefunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 35
[Wed Feb 17 15:18:58.671014 2021] [php7:notice] [pid 3624] [client 23.239.96.242:51145] PHP Notice: Undefined index: groupfunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 36
[Wed Feb 17 15:26:50.504695 2021] [php7:notice] [pid 3615] [client 73.249.195.236:53835] PHP Notice: Undefined index: task in /var/www/frweb/components/com_opensim/router.php on line 38, referer: www.forgottenrealities.com/index.php?opt...icle&id=1&Itemid=101
[Wed Feb 17 15:30:23.964537 2021] [php7:notice] [pid 3623] [client 23.239.96.242:52756] PHP Notice: Undefined index: profilefunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 35
[Wed Feb 17 15:30:23.964588 2021] [php7:notice] [pid 3623] [client 23.239.96.242:52756] PHP Notice: Undefined index: groupfunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 36
[Wed Feb 17 15:30:23.965155 2021] [php7:warn] [pid 3623] [client 23.239.96.242:52756] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 137
[Wed Feb 17 15:30:23.965178 2021] [php7:warn] [pid 3623] [client 23.239.96.242:52756] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 141
[Wed Feb 17 15:30:24.241700 2021] [php7:notice] [pid 3623] [client 23.239.96.242:52756] PHP Notice: Undefined index: profilefunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 35
[Wed Feb 17 15:30:24.241753 2021] [php7:notice] [pid 3623] [client 23.239.96.242:52756] PHP Notice: Undefined index: groupfunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 36
[Wed Feb 17 15:30:24.241921 2021] [php7:warn] [pid 3623] [client 23.239.96.242:52756] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 137
[Wed Feb 17 15:30:24.241947 2021] [php7:warn] [pid 3623] [client 23.239.96.242:52756] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 141
[Wed Feb 17 15:30:24.496435 2021] [php7:notice] [pid 3623] [client 23.239.96.242:52756] PHP Notice: Undefined index: profilefunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 35
[Wed Feb 17 15:30:24.496483 2021] [php7:notice] [pid 3623] [client 23.239.96.242:52756] PHP Notice: Undefined index: groupfunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 36
[Wed Feb 17 15:30:24.496649 2021] [php7:warn] [pid 3623] [client 23.239.96.242:52756] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 137
[Wed Feb 17 15:30:24.496674 2021] [php7:warn] [pid 3623] [client 23.239.96.242:52756] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 141
[Wed Feb 17 15:30:24.748338 2021] [php7:notice] [pid 3623] [client 23.239.96.242:52756] PHP Notice: Undefined index: profilefunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 35
[Wed Feb 17 15:30:24.748385 2021] [php7:notice] [pid 3623] [client 23.239.96.242:52756] PHP Notice: Undefined index: groupfunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 36
[Wed Feb 17 15:30:24.748607 2021] [php7:warn] [pid 3623] [client 23.239.96.242:52756] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 137
[Wed Feb 17 15:30:24.748631 2021] [php7:warn] [pid 3623] [client 23.239.96.242:52756] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 141
[Wed Feb 17 15:35:07.267566 2021] [php7:notice] [pid 3616] [client 23.239.96.242:53420] PHP Notice: Undefined index: profilefunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 35
[Wed Feb 17 15:35:07.267616 2021] [php7:notice] [pid 3616] [client 23.239.96.242:53420] PHP Notice: Undefined index: groupfunctions in /var/www/frweb/components/com_opensim/views/interface/view.html.php on line 36

Please Log in or Create an account to join the conversation.

1 week 1 day ago #3560 by foto50
Hi Ton

Thanks for this error log ... it shows 2 PHP notices that can be fixed in next version ;) They are not errors and got nothing to do with your issue, but help in keeping code clean. I assume u have not enabled jOpenSim group functions?

The error "The inventory service is not responding" is sure something different though. Can it be that you defined a different connection string for the inventory service in your ini files? Even when not offering an avatar, OpenSim needs to know a root folder for the users inventory.

The database table name where jOpenSim wants to create it is called "inventoryfolders" and expects it to be in the robust database.

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

1 week 1 day ago #3561 by Ton
Hi Foto50, so I agree with you that the step that isn't being done is the creation of the inventory folders.

None of the connection strings have been altered from prior to the upgrade to now. I can confirm that the inventoryfolders table is in the Robust database and that the connection string in the jOpensim setup indeed points to the robust server's database.

I will check the MySQL database logs to see if there is an issue that shows why the creation of the inventory folders might be failing.

As I think I mentioned, this all started when we upgraded from Ununtu 16 to 20 and PHP 7.2 to php7.4. I am wondering if there is something that was "held back" in those upgrades, or a PHP extension that is used that is not installed by default in 7.4.

I ran the Joomla Forum Post Assistant against my Joomla installation to see if it highlighted any issues, but I don't see anything jumping out at me. I have attached it for your information, in case something strikes you as wrong.

I appreciate your help.

Ton.
Attachments:

Please Log in or Create an account to join the conversation.

1 week 22 hours ago #3563 by Ton
Also, in regards to your comment "Can it be that you defined a different connection string for the inventory service in your ini files? Even when not offering an avatar, OpenSim needs to know a root folder for the users inventory." where in jOpensim is the same connection string set as in the robust.hg.ini file? I want to double check that although I have to think that if this was incorrect the whole thing would break :)

Cheers!

Please Log in or Create an account to join the conversation.

5 days 22 hours ago #3565 by Ton
Hi Foto50

So I am trying to find where this process is failing. When I went into inventory folders there were none. So I turned on general logging temporarily, just to see if I could capture the events. In the attachment I see the inventory folders being created, but then after they are created they all seem to be deleted by the last statement deleting everything for that agentID/UUID, so I'm confused as to, if I'm reading the correctly, why it would be deleting everything that was just created.

Let me know if I'm barking up the wrong tree.

Thanks,
Ton.
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.225 seconds

Search

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
Basilic… 1007 1000
Bay Sho… 997 1003
Boardwa… 1003 1004
BoraBor… 1002 999
Canary … 997 999
Creator… 990 990
Crystal… 1001 1000
DeepTho… 1005 998
FoToSan… 996 995
jAdult 1003 1003
jCity 1001 997
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
LindaKe… 1000 997
MonteSc… 1001 1001
Mountai… 1009 1000
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
Tropica… 1004 1003
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

Donate jOpenSim

Please consider supporting our efforts.

Amount