× Creating OpenSim accounts during Joomla! registration

Issue with jOpenSimRegister

3 weeks 5 days ago #3070 by Mark Shadowblade
I noticed there was a bug in the jOpenSimRegister plugin. I did some research and found the problem after turning Debugging on. I'm running the web server on Ubuntu 18.04, Apache2, php7.2. This is the issue:

/plugins/user/jopensimregister/jopensimregister.php

Line 68 it has JSite::getMenu()
Needs to be changed to JFactory::getApplication()->getMenu()

The change looks like this:

$menu = &JFactory::getApplication()->getMenu();

After I made the change, users could now see the confirmation notice that their account has been made. I hope this helps people.
The following user(s) said Thank You: foto50

Please Log in or Create an account to join the conversation.

3 weeks 2 days ago #3071 by foto50
Hi Mark

Thanks very much for this info, will be added in next version (probably in a month or 2) :)

The & needs to be removed for php 7.x since it would cause a notice (Only variables should be assigned by reference...), but thanks very much pointing me to this issue :)

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

Time to create page: 0.125 seconds

Search

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
Basilic… 1007 1000
Bay Sho… 997 1003
Boardwa… 1003 1004
BoraBor… 1002 999
Canary … 997 999
Creator… 990 990
Crystal… 1001 1000
DeepTho… 1005 998
Fantasy 1009 1004
FoToSan… 996 995
Hiatus 1007 1004
jAdult 1003 1003
jCity 1009 1003
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
Kansas 1007 1003
Kodu 980 983
LindaKe… 1000 997
MA2 1008 1003
MA5 1008 1004
MonteSc… 1001 1001
Mountai… 1009 1000
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
Tropica… 1004 1003
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

Donate jOpenSim

Please consider supporting our efforts.

Amount: