Can not install to Joomla 3.19x

5 months 2 weeks ago #3262 by VinnyB
Hello,

I have Joomla v. 3.19.13,2,5.28 installed on my website vbcreations.us. I am trying to install com_opensim.0.3.1.5 and gett an error stating
"Warning
Specified key was too long; max key length is 1000 bytes"
"Error
Error installing component"

I already have a server running with v. 0.9.0.1 and would lei to interface Joomla with it.
Am I missing something in setting this up? The com_ and all mod_ etc. come up with errors.
Any help would be appreciated.
Thanks
Vinny

Please Log in or Create an account to join the conversation.

5 months 2 weeks ago #3263 by foto50
Hi VinnyB

This is most likely an issue concerning MySQL/MariaDB.

Is there any detailed error information about what table is trying to be created?

What version is running there and what is the default storage engine?

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

5 months 2 weeks ago #3265 by VinnyB
Hi, Thanks for your reply.
I did not see any errors that were specific except what I listed.
The version of MySQL I think is 7.x I think this error has something to do with the table length being too long. Maybe this will give you an idea.
stackoverflow.com/questions/6157823/spec...length-is-1000-bytes .
I haven't worked wit Joomla in years and at that time I knew all the workarounds when needed. I do not recall ever seeing this error. I spent another hour on this again and did not get anywhere.

Please Log in or Create an account to join the conversation.

5 months 2 weeks ago #3266 by VinnyB
P.S. is there any way to change the font type in this forum? I am having a hard time being able to read the text. Old eyes here...

Please Log in or Create an account to join the conversation.

5 months 2 weeks ago #3267 by VinnyB
Actually I may not be trying to install the right item? I downloaded all the items, but I did not see a step by step of what to first install .etc.etc.

Thanks

Please Log in or Create an account to join the conversation.

5 months 2 weeks ago #3268 by foto50
Hi VinnyB

About the font: most browsers have a zoom function ;) usually with the shortcuts Strg+ and Strg-

I doubt u have MySQL version 7.x since such a version never was released (they jumped from 5.7 directly to 8 ), so my guess is 7.x here is your PHP version which most probably got nothing to do with this issue. Also the version of your Joomla is probably a typo. We currently have 3.9.13 ;)

For installation of jOpenSim, the basic component (com_opensim.0.3.1.5.zip) is a good start, but the package (pkg_jopensim.0.3.1.5.zip) might be the easiest way since it installs all modules and plugins as well in one go.

Back to your "1000 bytes" problem: the link provided is similar to what I asked before (default storage engine?) but without further details everything is just a wild guess.

Do you have access to the joomla database (e.g. via phpMyAdmin)? What tables can you find starting with #__opensim_* (replace #__ with your own joomla prefix).

Suspecting your database server has an issue creating some index, we could maybe find the one causing it since this table and all behind it should be missing in the database.

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

5 months 2 weeks ago #3269 by VinnyB
I tried this file " pkg_jopensim.0.3.1.5.zip" and the same error. prntscr.com/q95sly

The host site is Linux. it is a free hosting service called infinityfree.net I do not know much about the workings of the host. Again this is the first time I have had any errors installing anything into Joomla. I used to be very proficient at it even took a class for it, but that was when Joomla first came out and it has been so long ago. I am sorry I cannot precisely answer your question. I am mostly a plug and play person now.

Please Log in or Create an account to join the conversation.

5 months 1 week ago #3270 by foto50
Well, without more details it is impossible to locate the issue.

And sorry to say, but OpenSimulator itself is definately nothing to "plug and play" :dry:

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

5 months 1 week ago #3271 by VinnyB
What information do you actually need in laymen's terms?
I have a simulator already running on a separate server here at my home. I just do not understand what information you need.
This "with #__opensim_* (replace #__ with your own joomla prefix)"
is all correct with my prefix and there is nothing showing for OpenSim just the Joomla database with no Opensim additions..
The Joomla database is fins since I have no issues installing other items to it such as modules etc. I even installed a fresh Joomla and still the same issue.

Please Log in or Create an account to join the conversation.

5 months 1 week ago #3272 by andrewheritage
May be not relevant at all but I read that the error could mean that you require the InnoDB storage engine for MySQL, but that’s not available on the free hosting package with infinityfree.net
The following user(s) said Thank You: foto50

Please Log in or Create an account to join the conversation.

Time to create page: 0.305 seconds

Search

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
Basilic… 1007 1000
Bay Sho… 997 1003
Boardwa… 1003 1004
BoraBor… 1002 999
Canary … 997 999
Creator… 990 990
Crystal… 1001 1000
DeepTho… 1005 998
Fantasy 1009 1004
FoToSan… 996 995
Hiatus 1007 1004
jAdult 1003 1003
jCity 1009 1003
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
Kansas 1007 1003
Kodu 980 983
LindaKe… 1000 997
MA2 1008 1003
MA5 1008 1004
MonteSc… 1001 1001
Mountai… 1009 1000
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
Tropica… 1004 1003
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

Donate jOpenSim

Please consider supporting our efforts.

Amount