Struggling to get Profiles working

6 months 2 weeks ago #3072 by zephy
I've got a fresh install of OpenSim and worked through the ini config info in the jopensim back end, but as soon as my avatar enters a region the jOpenSimProfile fails to work with the following errors logged:
2019-02-10 20:47:15,250 INFO  [SCENE PRESENCE]: Completing movement of Cnayl Rainbow into region Mintor in position <128, 128, 0>
2019-02-10 20:47:15,485 DEBUG [CompleteMovement]: Missing COF for a7f024c0-3697-4adf-a99b-cbaf2b959168 is aa477dda-1399-4e09-907a-6322dbb7db08
2019-02-10 20:47:15,582 DEBUG [AgentPrefs]: UpdateAgentPreferences for a7f024c0-3697-4adf-a99b-cbaf2b959168
2019-02-10 20:47:16,136 DEBUG [CompleteMovement] end: 886ms
2019-02-10 20:47:16,398 DEBUG [jOpenSimProfile] Secure?? GenericXMLRPCRequest for method avatar_properties_request = System.Net.Security.RemoteCertificateValidationCallback
2019-02-10 20:47:16,408 ERROR [jOpenSimProfile]: Unable to connect to Profile Server https://world.quintonia.net/components/com_opensim/interface.php.  Exception System.Net.WebException: Error:$
  at Mono.Security.Protocol.Tls.RecordProtocol.EndReceiveRecord (System.IAsyncResult asyncResult) [0x00040] in <1d0bb82c94e7435eb09324cf5ef20e36>:0
  at Mono.Security.Protocol.Tls.SslClientStream.SafeEndReceiveRecord (System.IAsyncResult ar, System.Boolean ignoreEmpty) [0x00000] in <1d0bb82c94e7435eb09324cf5ef20e36>:0
  at Mono.Security.Protocol.Tls.SslClientStream.NegotiateAsyncWorker (System.IAsyncResult result) [0x00071] in <1d0bb82c94e7435eb09324cf5ef20e36>:0
   --- End of inner exception stack trace ---
  at Mono.Security.Protocol.Tls.SslClientStream.EndNegotiateHandshake (System.IAsyncResult result) [0x0003b] in <1d0bb82c94e7435eb09324cf5ef20e36>:0
  at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (System.IAsyncResult asyncResult) [0x0000c] in <1d0bb82c94e7435eb09324cf5ef20e36>:0  ---> System.IO.IOException: Unable to w$
  at System.Net.Sockets.Socket.EndSend (System.IAsyncResult result) [0x00033] in <bd46d4d4f7964dfa9beea098499ab597>:0
  at System.Net.Sockets.NetworkStream.EndWrite (System.IAsyncResult asyncResult) [0x0005f] in <bd46d4d4f7964dfa9beea098499ab597>:0
   --- End of inner exception stack trace ---

Any thoughts/pointers greatly appreciated! Thanks

Please Log in or Create an account to join the conversation.

6 months 1 week ago #3073 by foto50
Hi zephy,

and welcome to jOpenSim :)

It seems to me you have some conflict with url's. You should not use same url for website and grid, even if website would use only ssl port.

It is better to use a subdomain for the grid (e.g. website = www.mydomain.com , opensim = grid.mydomain.com) since OpenSim is also listening on port 80 (and if set on 443).

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

6 months 1 week ago #3074 by zephy
Thanks, one of those things that seem obvious once it's pointed out!
I managed to get thing working apart from Groups - I've started with a clean install of opensim and only made the changes mentioned in Addon section so not sure if I need to do any other changes? What happens at the moment is that I can get the create group box up and when I click to create it the message says it will cost OS$-1 which seems a bit odd? If I click to create it then it just goes back to showing the main Create new group box. No messages at all in either Robust or OpenSim console or logs. I also tried turning on the debug option in jOpensim but nothing there either!

Please Log in or Create an account to join the conversation.

6 months 1 week ago #3076 by foto50
Hi Zephi

Hmmm, can it be that you have the addon jOpenSimMoney enabled but for some reason that module is disabled in OpenSim?

Please Log in or Create an account to join the conversation.

6 months 1 week ago #3078 by zephy
Alas no - I haven't touched jOpenSimMoney. I have a fresh install of opensim-0.9.0.1 configured in grid (hypergrid enabled) and then set up for profiles, offline messaging etc via the info in jOpenSim and they all work fine apart from the groups.

I did remove the comment in OpenSim.ini for PriceGroupCreate = 0 even though it says it uses 0 by default, and that at least makes it now show the price as 0, but still the same behaviour.

I haven't done any of the things mentioned at opensimulator.org/wiki/Groups as I thought that just using the info for jopensim groups would do the trick?

Please Log in or Create an account to join the conversation.

6 months 1 week ago #3079 by zephy
:blush: Ah sorry, in checking the settings again I found somehow "Enabled" was false - no suprise setting it to True gets things working!

Have to say as a lover of both OpenSim & Joomla I'm finding using jIpenSim amazing! Thanks for creating it.

Please Log in or Create an account to join the conversation.

6 months 1 week ago #3080 by foto50
Hi Zephy

Happy it works now :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.143 seconds

Search

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
Basilic… 1007 1000
Bay Sho… 997 1003
Boardwa… 1003 1004
BoraBor… 1002 999
Canary … 997 999
Creator… 990 990
Crystal… 1001 1000
DeepTho… 1005 998
Fantasy 1009 1004
FoToSan… 996 995
Hiatus 1007 1004
jAdult 1003 1003
jCity 1009 1003
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
Kansas 1007 1003
Kodu 980 983
LindaKe… 1000 997
MA2 1008 1003
MA5 1008 1004
MonteSc… 1001 1001
Mountai… 1009 1000
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
Tropica… 1004 1003
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

Donate jOpenSim

Please consider supporting our efforts.

Amount