jOpenSimWorld

Grid Status: Online
Total Regions: 21
Visitors (30 Days): 12
Total Residents: 442
Online Now: 0
Hypergriders online: 0

Hypergrid vs Grid Questions

4 years 10 months ago #2549 by fungi
Everything is behind a Cisco ASA5506x-W Router, I can Nat and Hairpin, I have csf/lfd firewalls on my Centos 7 Systems, for Troubleshooting purposes I have temporarily disabled Modsec. I have Virtualmin and Bind Management stuff with Webmin. Opensim is installed and works in Stand Alone. I have 13 IP Addresses I can use. In this message I had too many html links so i replaced my http colon slashslash domainname with HTMLLINK

Im running latest stable release of Joomla, Opensim, Jopensim.

SCENARIO 1
Scenario 1, Tried Grid Mode, Although everything is behind the same ASA5506 Router, My Bare Metal Server is using esxi server with multiple vms all Centos 7 with unique public and private ip's Robust , Joomla, Opensim and Jopensim on the same server VM., Concurrently,
I also ran an additional opensimulator in another VM with a unique private and public ip's, I tried both IP's and Domain Names and was able to get grid region to register with Robust, However could not get the user to sign in with firestorm viewer. The login was denied, didnt matter which region i tried to log into. didnt try any other viewers
No Warnings, No Errors. But couldnt log in. I am able to access the domains from inside and outside of the network, the IP's too. WTF? haha Should I be using Inside addresses for any part of this config for sim to sim, sim to robust or anything like that? I went all Domain Name or All IP and had the same results.

SCENARIO 2

Scenario 2. I set up Stand Alone It works Fine. Jopensim works pretty well it is installed on the same VM and Domain as Opensim is configured for. It worked, So I installed jopensimmoney. I just get some errors about jopensimmoney and xmlrpc but the simulator does come up. Here are some of the errors with some of the log data redacted for readability related to the issues as I figure.

2017-02-27 14:21:23,801 INFO (1) - jOpenSim.Profile.jOpenProfile.OpenProfileModule [jOpenSimProfile] activated, communicating with HTMLLINK/3d/components/com_opensim/interface.php
2017-02-27 14:21:23,804 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: Die Konfig hamma gelesen!
2017-02-27 14:21:23,804 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: ServUrl: HTMLLINK/3d/components/com_opensim/currency.php
2017-02-27 14:21:23,821 INFO (1) - OpenSim.Region.OptionalModules.Avatar.XmlRpcGroups.GroupsMessagingModule [GROUPS-MESSAGING]: GroupsMessagingModule enabled with MessageOnlineOnly = False, DebugEnabled = False
2017-02-27 14:21:23,823 INFO (1) - OpenSim.Region.OptionalModules.Avatar.XmlRpcGroups.GroupsModule [GROUPS]: Initializing GroupsModule
2017-02-27 14:21:23,826 DEBUG (1) - OpenSim.Region.OptionalModules.Avatar.XmlRpcGroups.XmlRpcGroupsServicesConnectorModule [XMLRPC-GROUPS-CONNECTOR]: Initializing XmlRpcGroupsServicesConnector
2017-02-27 14:21:23,827 INFO (1) - OpenSim.Region.OptionalModules.Avatar.XmlRpcGroups.XmlRpcGroupsServicesConnectorModule [XMLRPC-GROUPS-CONNECTOR]: Groups Cache Timeout set to 30.
2017-02-27 14:21:23,849 DEBUG (1) - OpenSim.ApplicationPlugins.RemoteController.RemoteAdminPlugin [RADMIN]: Remote Admin Plugin Enabled
2017-02-27 14:21:23,855 DEBUG (1) - OpenSim.Region.CoreModules.Avatar.InstantMessage.MuteListModule [MUTE LIST] Mute list enabled
2017-02-27 14:21:23,856 DEBUG (1) - OpenSim.Region.CoreModules.Avatar.InstantMessage.OfflineMessageModule [OFFLINE MESSAGING] Offline messages enabled
2017-02-27 14:21:23,857 INFO (1) - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: Starting HTTP server on port 20800
2017-02-27 14:21:23,859 DEBUG (1) - OpenSim.Framework.Monitoring.Watchdog [WATCHDOG]: Started tracking thread PollServiceWorkerThread0:20800, ID 32
2017-02-27 14:21:23,859 DEBUG (1) - OpenSim.Framework.Monitoring.Watchdog [WATCHDOG]: Started tracking thread PollServiceWorkerThread1:20800, ID 33
2017-02-27 14:21:23,860 DEBUG (1) - OpenSim.Framework.Monitoring.Watchdog [WATCHDOG]: Started tracking thread PollServiceWorkerThread2:20800, ID 34
2017-02-27 14:21:23,860 DEBUG (1) - OpenSim.Framework.Monitoring.Watchdog [WATCHDOG]: Started tracking thread LongPollServiceWatcherThread:20800, ID 35
2017-02-27 14:21:23,861 INFO (1) - OpenSim.Region.CoreModules.ServiceConnectorsIn.Login.LLLoginServiceInConnectorModule [LLLOGIN IN CONNECTOR]: Starting...
2017-02-27 14:21:23,864 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: ##### PostInitialise #####
2017-02-27 14:21:23,865 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getSettingDataInt uploadCharge
2017-02-27 14:21:23,866 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] genericCurrencyXMLRPCRequest with method getSettingsData
2017-02-27 14:22:13,919 ERROR (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: Unable to connect to Money Server HTMLLINK/3d/components/com_opensim/currency.php. Exception System.Net.WebException: The request timed out
at System.Net.HttpWebRequest.GetRequestStream () <0x41b9a710 + 0x0015f> in <filename unknown>:0
at Nwc.XmlRpc.XmlRpcRequest.Send (System.String url, Int32 timeout) <0x41b948f0 + 0x00199> in <filename unknown>:0
at OpenSim.Modules.Currency.jOpenSimMoneyModule.genericCurrencyXMLRPCRequest (System.Collections.Hashtable reqParams, System.String method) <0x41b94030 + 0x001ff> in <filename unknown>:0
2017-02-27 14:22:13,924 ERROR (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getSettingDataInt - Error for uploadCharge:
2017-02-27 14:22:13,924 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getSettingDataInt groupCharge
2017-02-27 14:22:13,924 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] genericCurrencyXMLRPCRequest with method getSettingsData
2017-02-27 14:23:03,940 ERROR (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: Unable to connect to Money Server HTMLLINK/3d/components/com_opensim/currency.php. Exception System.Net.WebException: The request timed out
at System.Net.HttpWebRequest.GetRequestStream () <0x41b9a710 + 0x0015f> in <filename unknown>:0
at Nwc.XmlRpc.XmlRpcRequest.Send (System.String url, Int32 timeout) <0x41b948f0 + 0x00199> in <filename unknown>:0
at OpenSim.Modules.Currency.jOpenSimMoneyModule.genericCurrencyXMLRPCRequest (System.Collections.Hashtable reqParams, System.String method) <0x41b94030 + 0x001ff> in <filename unknown>:0
2017-02-27 14:23:03,940 ERROR (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getSettingDataInt - Error for groupCharge:

I SOme Log Data Redacted for Readability Here is more error stuff

2017-02-27 14:23:04,145 INFO (1) - OpenSim.Region.DataSnapshot.SnapshotStore [DATASNAPSHOT]: Response and fragment cache directory already exists.
2017-02-27 14:23:04,146 INFO (1) - OpenSim.Region.DataSnapshot.DataRequestHandler [DATASNAPSHOT]: Set up snapshot service
2017-02-27 14:25:11,424 ERROR (1) - OpenSim.Framework.RestClient [REST CLIENT] Error fetching resource from server: HTMLLINK/3d/components/com_opensim/registersearch.php?service=online&host=rainbowhq.com&port=9000&secret=203756f0-832b-49be-a764-076857bf6e4f
System.Net.WebException: Error: ConnectFailure (Connection timed out) ---> System.Net.Sockets.SocketException: Connection timed out
at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remoteEP) <0x41b9f550 + 0x0019b> in <filename unknown>:0
at System.Net.WebConnection.Connect (System.Net.HttpWebRequest request) <0x41b9e700 + 0x0058b> in <filename unknown>:0
--- End of inner exception stack trace ---
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0x41bd3eb0 + 0x00197> in <filename unknown>:0
at System.Net.HttpWebRequest.GetResponse () <0x41bd2930 + 0x00053> in <filename unknown>:0
at OpenSim.Framework.RestClient.Request (IServiceAuth auth) <0x41bd1940 + 0x00403> in <filename unknown>:0
2017-02-27 14:25:11,427 WARN (1) - OpenSim.Region.DataSnapshot.DataSnapshotManager [DATASNAPSHOT]: Unable to decode reply from data service. Ignoring. at OpenSim.Region.DataSnapshot.DataSnapshotManager.NotifyDataServices (System.String servicesStr, System.String serviceName) <0x41bd08d0 + 0x0035b> in <filename unknown>:0

More Log Redacted by me

OpenSim.Region.CoreModules.ServiceConnectorsOut.UserAccounts.LocalUserAccountServicesConnector [LOCAL USER ACCOUNT SERVICE CONNECTOR]: Enabled local user accounts for region RainbowHQ
2017-02-27 14:25:12,103 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: ##### RegionLoaded #####
2017-02-27 14:25:12,104 WARN (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: I am in D E M O - M O D E ! ! !
2017-02-27 14:25:12,104 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: ##### getBankerUUID #####
2017-02-27 14:25:12,105 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getSettingDataString bankerUID
2017-02-27 14:25:12,105 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] genericCurrencyXMLRPCRequest with method getSettingsData
2017-02-27 14:26:02,116 ERROR (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: Unable to connect to Money Server HTMLLINK/3d/components/com_opensim/currency.php. Exception System.Net.WebException: The request timed out
at System.Net.HttpWebRequest.GetRequestStream () <0x41b9a710 + 0x0015f> in <filename unknown>:0
at Nwc.XmlRpc.XmlRpcRequest.Send (System.String url, Int32 timeout) <0x41b948f0 + 0x00199> in <filename unknown>:0
at OpenSim.Modules.Currency.jOpenSimMoneyModule.genericCurrencyXMLRPCRequest (System.Collections.Hashtable reqParams, System.String method) <0x41b94030 + 0x001ff> in <filename unknown>:0
2017-02-27 14:26:02,117 ERROR (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getSettingDataString - Error for bankerUID:
2017-02-27 14:26:02,117 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getBankerUUID --> old: 00000000-0000-0000-0000-000000000000, new:
2017-02-27 14:26:02,118 ERROR (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: banker account not found (missing in jOpenSim?), MODULE IS DISABLED!
2017-02-27 14:26:02,118 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: ##### getCurrencyName #####
2017-02-27 14:26:02,119 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getSettingDataString currencyName
2017-02-27 14:26:02,119 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] genericCurrencyXMLRPCRequest with method getSettingsData
2017-02-27 14:26:52,131 ERROR (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: Unable to connect to Money Server HTMLLINK/3d/components/com_opensim/currency.php. Exception System.Net.WebException: The request timed out
at System.Net.HttpWebRequest.GetRequestStream () <0x41b9a710 + 0x0015f> in <filename unknown>:0
at Nwc.XmlRpc.XmlRpcRequest.Send (System.String url, Int32 timeout) <0x41b948f0 + 0x00199> in <filename unknown>:0
at OpenSim.Modules.Currency.jOpenSimMoneyModule.genericCurrencyXMLRPCRequest (System.Collections.Hashtable reqParams, System.String method) <0x41b94030 + 0x001ff> in <filename unknown>:0
2017-02-27 14:26:52,131 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getCurrencyName:
2017-02-27 14:26:52,132 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: CurrencySymbol:
2017-02-27 14:26:52,132 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: ##### getStartBalance #####
2017-02-27 14:26:52,132 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] getSettingDataString startBalance
2017-02-27 14:26:52,132 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY] genericCurrencyXMLRPCRequest with method getSettingsData
2017-02-27 14:27:42,144 ERROR (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule [jOpenSimMONEY]: Unable to connect to Money Server HTMLLINK/3d/components/com_opensim/currency.php. Exception System.Net.WebException: The request timed out
at System.Net.HttpWebRequest.GetRequestStream () <0x41b9a710 + 0x0015f> in <filename unknown>:0
at Nwc.XmlRpc.XmlRpcRequest.Send (System.String url, Int32 timeout) <0x41b948f0 + 0x00199> in <filename unknown>:0
at OpenSim.Modules.Currency.jOpenSimMoneyModule.genericCurrencyXMLRPCRequest (System.Collections.Hashtable reqParams, System.String method) <0x41b94030 + 0x001ff> in <filename unknown>:0
2017-02-27 14:27:42,145 DEBUG (1) - OpenSim.Modules.Currency.jOpenSimMoneyModule <log4net.Error>Exception during StringFormat: Index (zero based) must be greater than or equal to zero and less than the size of the argument list. <format>[{0}] getStartBalance --> {2}</format><args>{jOpenSimMONEY, }</args></log4net.Error>
2017-02-27 14:27:42,164 DEBUG (1) - OpenSim.Region.DataSnapshot.DataSnapshotManager [DATASNAPSHOT]: Marking scene RainbowHQ as stale.OpenSim.Region.Framework.Scenes.SceneCommunicationService [SCENE

More Redacted Log Data by me

COMMUNICATION SERVICE] Informing 0 neighbours that region RainbowHQ is up

Before I put in the Money Module, It worked fine, Although it is in stand alone, OS, JOS, JOSMONEY, Joomla, All in same server instance.

I really want this to work to the best of it's ability and am running into some caveats. Come of it certainly looks like it is network related but Looks can be deceiving. And I am pulling hair. :)

Thoughts?

Please Log in or Create an account to join the conversation.

4 years 10 months ago #2550 by BillBlight
Just a quick question before I try to wade in on your first question .. When you are connecting to your sim are you connecting to the outside or private IP, ie which one are you using for your login uri ?

Please Log in or Create an account to join the conversation.

4 years 10 months ago #2551 by foto50
Hi fungi

... I have 13 IP Addresses I can use ...


For security, jOpenSim will not answer any IP address, that is not known from the region table in OpenSim's database. This could explain the "request timeouts" in the log.

Unfortuntely - if there are more IP's available - OpenSim will use them sometimes randomly. So it could be there is a differet IP address during registering to the grid than the one sending requests to jOpenSim.

To force the regions to a certain IP, you could try following:

After starting up, check out the table "regions" in the database of robust and see what value is in the column "ServerIP" for each region.

In each Region.ini you can add then:
ExternalHostName = your.ip.add.ress
instead of the default
ExternalHostName = SYSTEMIP

This forces the region to use this IP address and jOpenSim will recognize it as a valid request and respond.

Hope this helps
Greetz
FoTo50

Please Log in or Create an account to join the conversation.

4 years 10 months ago #2553 by fungi
Well, I cannot say it helped. But I will say, That after much moving pieces around, I have a configuration that seems to work well. It is a Stand Alone config, It looks like everything is working in Jopensim,

The Only error I see happening here is this one, Do you know what this causes or how I can Mitigate it? Im super happy that I can use Jopensim and access users, maps, etc, even send messages to world from remote admin. Still, Hate seeing red text on my console screen :)

[XMLRPC-GROUPS-CONNECTOR]: The XmlRpc server returned a System.Collections.ArrayList instead of a hashtable for groups.getAgentGroupMemberships
15:17:08 - [XMLRPC-GROUPS-CONNECTOR]: Contains 0 elements

Please Log in or Create an account to join the conversation.

4 years 10 months ago #2554 by BillBlight
Your using my .dlls .. Don't worry about that error ... Like I said, I have some force debug stuff for testing turned on ... This causes it to initialize before the groups is queried from the DB so it get's a empty response ..

Please Log in or Create an account to join the conversation.

4 years 10 months ago #2555 by BillBlight
You really should only see that the first time a user logs in or if there are NO groups in the db ...

(but like I said, it is a work in progress)

Please Log in or Create an account to join the conversation.

4 years 10 months ago #2556 by fungi
Ahh, Hi Watcher64, I never got my hands on the DLL's for 0.9 ver I looked but did not find. So I am using the latest stable binary build and getting this error. I did create a group and it worked. Ill check to make sure the debug setttings are off for groups.

Please Log in or Create an account to join the conversation.

4 years 10 months ago #2557 by BillBlight
Yeah I was having a total brain freeze .. that is kind of normal for the groups ... IF you were using my dlls you may see something very similar for profiles ...

And check your PMs I sent you a link to the .9dev versions a while back ...

Please Log in or Create an account to join the conversation.

Time to create page: 0.155 seconds

Search

Donate jOpenSim

Please consider supporting our efforts.

Amount

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
Bay Sho… 997 1003
BoraBor… 1002 999
Canary … 997 999
Crystal… 1001 1000
DeepTho… 1005 998
FoToSan… 996 995
jCity 1001 997
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
LindaKe… 1000 997
MonteSc… 1001 1001
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

jOpenSimWorld

Grid Status: Online
Total Regions: 21
Visitors (30 Days): 12
Total Residents: 442
Online Now: 0
Hypergriders online: 0